Jump to content
Sign in to follow this  
ULLISSES

Windows 7 (Seven) 32bit/64bit

Recommended Posts

panowie mam bardzo dziwna sytuacje

 

opisze ja od poczatku do konca :

system 7 x64

jest sobie laptop ( dell vostro ) ma 2 giga ramu oraz na plik wymiany ustawiony na stale o wielkosci 2 giga ... gram w Heroes of might & magic 5 , wszystko smiga jak ta lala ( zadnych bledow etc )

trafila sie okazja dokupilem 2 kostke ramu czyli traz juz jest tego ramu 4 giga , mysle sobie skoro 2giga ramu + 2 giga pliku wymiany dzila ok to nie zmieniajac i nie instalujac nic 4 giga ramu + wylaczony plik wymiany tez bedzie ok .. i co ? a no psikus

Gra chodzi ok ale po pewnym czasie system zaczyna meldowac ze nie ma pamieci i ubija mi proces ...

 

OCB nie uwierze ze 4 giga to za malo na taka gre ?

 

jakies pomysly ( teraz profilaktycznie wlaczylem 2 giga pliku wymiany i jest Ok ale nie daje mi to spokoju )

Share this post


Link to post
Share on other sites

Cały urok aplikacji 32bitowych - możesz mieć 16GB, a i tak maksymalnie zajmie w ramie 2GB (pomijając sztuczki w stylu 3GB awareness switch).

 

ALE Windows jest na tyle głupi/sprytny że może w swapie dodać tej aplikacji przestrzeni adresowej ile tylko jest w stanie. Przez tą przypadłość często trzeba włączyć swapa tylko po to żeby jakaś kiepsko napisana gra chodziła... Normalnie program powinien być na tyle zoptymalizowany żeby dynamicznie mieścić się w tych 2GB. Jak się programiście nie chce pisać procedur ładująych i usuwających dane w locie to zrzuca to na windę i plik wymiany.

Share this post


Link to post
Share on other sites

tylko ze w systemie 32bit ( XP ) po wylaczeniu swapu wszystko chodzilo wiec dzieje sie to tylko na x64 i lub 7

bo o ile potrafie zrozumiec ze program nie miesci w tych 2 Gigach , to nie uwierze ze nagle systemowi zacznie ramu brakowac

Share this post


Link to post
Share on other sites

Cały urok aplikacji 32bitowych - możesz mieć 16GB, a i tak maksymalnie zajmie w ramie 2GB (pomijając sztuczki w stylu 3GB awareness switch).

 

Cały urok aplikacji 32 bitowych jest taki ze wystarczy program skompilowac z dodaniem IMAGE_FILE_LARGE_ADDRESS_AWARE i w win64 moze sobie zaadresowac pełne 4GB.

Share this post


Link to post
Share on other sites

tylko ze w systemie 32bit ( XP ) po wylaczeniu swapu wszystko chodzilo wiec dzieje sie to tylko na x64 i lub 7

bo o ile potrafie zrozumiec ze program nie miesci w tych 2 Gigach , to nie uwierze ze nagle systemowi zacznie ramu brakowac

 

Systemu nie tyle brakuje ramu co ostrzeżenie o końcówce jest zbyt wysoko ustawione.

Share this post


Link to post
Share on other sites

Cały urok aplikacji 32 bitowych jest taki ze wystarczy program skompilowac z dodaniem IMAGE_FILE_LARGE_ADDRESS_AWARE i w win64 moze sobie zaadresowac pełne 4GB.

 

"Może"

 

I na tym przydatność tego przełącznika dla aplikacji 32bit się kończy - taki Oblivion potrafi dojechać do trzech giga, tylko że przy przejściu do kolejnego fragmentu mapy program wykrzacza się - jego wewnętrzne procedury nijak nie potrafią ogarnąć danych które zostały załadowane do ramu :P

 

Gdyby działało toto jak powinno, to polecano by na każdej stronie z optymalizacją Windows. A szkoda...

Edited by Aquarium

Share this post


Link to post
Share on other sites

Wersja BOX Home Premium zawiera obie płyty instalacyjne z Windows 7? (32bit i 64bit)

Jeśli nie to skąd mogę wziąć tą drugą wersję?

 

Czy mam prawo używać tylko tej wersji którą kupiłem?

Edited by Martines82

Share this post


Link to post
Share on other sites

@Martines82 - o ile dobrze pamiętam, to na pudełku z Windą powinieneś mieć wyraźnie zaznaczone, jaka to jest wersja 32/64bit.

Na płytach nie masz obu wersji (poprawcie mnie jeśli się mylę) i nie, nie możesz używać legalnie wersji 64bit jeśli masz licencję na 32bit.

  • Upvote 1
  • Downvote 1

Share this post


Link to post
Share on other sites

Wersja BOX Home Premium zawiera obie płyty instalacyjne z Windows 7? (32bit i 64bit)

 

Tak, są 2 płyty.

Mozna uzywac zamiennie.

 

2 płyty są w wersjach BOX i UPGRADE.

Edited by ZlyUser
  • Upvote 1

Share this post


Link to post
Share on other sites

powiedz gdzie to zmienic :>

 

Sam nie moge tego znaleźć. Ani w rejestrze ani w google...

Share this post


Link to post
Share on other sites

Jest SP1, również na windows update. Zainstalowałem, przeżyłem.

Share this post


Link to post
Share on other sites

to usuń tempy i uninstall information, raczej nie będziesz odinstalowywał

Share this post


Link to post
Share on other sites

U mnie się nie chciał zainstalować anie przez WU ani z zewnętrznego instalatora (z włączonym jak i wyłączonym Comodo IS). W efekcie dostawałem takie info:

Dołączona grafika

Share this post


Link to post
Share on other sites

Witam, mam pewien problem, od pewnego czasu nękają mnie bluescreen'y o kodzie błędu 0x0000001e czego to może być przyczyną ? Może dyski mam takie: Seagate ST3500418AS - 500 GB, ma niespełna 6 miesięcy, drugi Western Digital WDC WD3200AAKS-00B3A0 - 320 GB - tego mam z 1,5 roku, no i ostatni (podziw dla niego) Seagate ST380817AS 80 GB - a tego mam z jakieś 6 lat :D, dyski przeskanowałem w programie HDTune 4.60 Pro pierwsze dwa OK a ten sześcioletni mnie zaniepokoił, brak badsectorów, ale w zakładce health niebędę pisał tylko wrzucę zdjęcie, czy te bluescreen'y mogą być spowodowane tym dyskiem ? czy to kompletnie co innego ? proszę o pomoc a i kompa czyściłem całego, tempy nie są za duże pamięci przeszły memtest bez problemów płyta bez wybrzuszeń na kondensatorkach i proc po lekkim O/C ale nie sądze żeby to było przyczyną, system wgrywałem na nowo (też po bluescreenie) 8 lutego, zasilacz mam dobry, cóż sam niewiem.

screen z hdtune:

screen

z góry dzięki za pomoc i pozdrawiam.

Edited by patmil18

Share this post


Link to post
Share on other sites

Brak screena...

 

Odepnij poza systemowe dyski na próbe, odepnij wszystkie nie potrzebne urządzenia USB. One często są przyczyną BSODów - może instalowałeś jakieś nowe urządzenie lub sterownik?

Share this post


Link to post
Share on other sites

Brak screena...

A był

tu jest ten screen nie wstawiam bo znowu zniknie screen . Nowych urządzeń nie instalowałem, nowych sterowników też.

Pozdrawiam i jutro zajmę się odpinaniem dysków i wszystkiego co mam na usb (oprócz klawiatury i myszki rzecz jasna)

Edited by patmil18

Share this post


Link to post
Share on other sites

Tak czy siak sprawdź co napisałem. Nie odniosłeś się do urządzęń na USB ewentualnie jakichś innych zmian w kompie. BTW na cholerę Ci taki stary dysk w kompie?

Share this post


Link to post
Share on other sites

U mnie się nie chciał zainstalować anie przez WU ani z zewnętrznego instalatora (z włączonym jak i wyłączonym Comodo IS). W efekcie dostawałem takie info:

http://static2.blip.pl/user_generated/update_pictures/1701209.png

 

Wyłączyłem w Defense+ kilka opcji, które wg mnie mogły zakłócać instalację, użyłem czegoś takiego jak Autonomiczny instalator aktualizacji od Microsoftu, który zainstalował jakąś łatkę i po restarcie instalacja SP1 zakończyła się sukcesem.

Share this post


Link to post
Share on other sites

czy istnieje jakiś sposób na zmianę nazwy katalogu użytkownika w "C:\Users\nazwa_uzytkownika" ? Oddałem poprzednio używany przez siebie komputer dziewczynie, zmieniłem wyświetlaną nazwę użytkownika w "Panel Sterowania - Konta użytkowników - Zmień swoją nazwę konta", jednak nazwa katalogu dalej pozostała ta sama. Zmieniła się tylko nazwa konta przy logowaniu do systemu... teoretycznie mógłbym założyć nowe konto a stare skasować, mam jednak trochę rzeczy poustawianych i szkoda mi czasu na zabawy w ustawianie od nowa.

Edited by E57

Share this post


Link to post
Share on other sites

Problemem jest pewnie visual C++ - na 64bit systemie instalujesz i x64, i x86, dla aplikacji 32 i 64 bitowych. Trainery są pewnie x86, a zgaduje, że zainstalowałeś Vs C++ tylko w wersji x64 - jak każdy przesiadający się na system x64.

Share this post


Link to post
Share on other sites

Problem jest taki ze mamy tyle informacji ze nic nie wiemy.

Wymagany net framework? Który?

Microsoft Visual C++? Tylko tyle? Na pewno? Microsoft Visual C++ to całe IDE...

Moze chodzi o same biblioteki? Wypadałoby wiedziec w jakiej wersji.

Microsoft Visual C++ 2005 Redistributable Package

Microsoft Visual C++ 2008 Redistributable Package

Microsoft Visual C++ 2010 Redistributable Package

W wersjach x86? X64?

 

Z drugiej strony jezeli wymaga frameworka to po kiego mu biblioteki c++? Program albo jest pisany w .Net albo nie jest.

Edited by ZlyUser

Share this post


Link to post
Share on other sites

Może tu ktoś mi pomoże :unsure:

 

Mam problem z usb. Softowy problem.

Zniknęły mi wszystkie "napędy" od czytnika kart i nic na usb nie działa prócz myszki i klawy. Peny, bluetooth - nic. Patrze w menadżer urządzeń a tu parę wykrzykników przy USB :blink: Odinstalowałem stery USB przez catalyst, wszystko wróciło do normy, zainstalowałem na nowo - znowu kiszka! Z poziomu menadżera urządzeń odinstalowałem, odświeżyłem, zainstalował sobie i działa do czasu kolejnego restartu kompa. Aby odczytać pena albo uruchomić bluetooth musze za każdym razem zrobić w/w czynność co jest męczące. Wygląda to tak:

 

post-164893-0-78381900-1299194505_thumb.jpg

 

Any ideas? :mad:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.