Jump to content
czolgerson17

KOTOR na Win7 + kilka inych problemów

Recommended Posts

Witam.

Zakupiłem sobie właśnie pierwszą część KOTORa, za niebagatelną cenę 40zł i krew mnie się gotuję przez Windowsa 7. Żeby nie było można pograć w takie gry przez głupi system - skandal! Jakbym wiedział to bym sobie kupił co innego, ale cóż trzeba jakoś rozwiązać zaistniały problem.

To tak, gra instaluje się, wszystko pięknie, odpalam pokazuje się logo Lukasa później Bioware i gre wywala a raczej minimalizuje do Windowsa (7;/). Po zmianie zgodności na Viste SP2 i 'uruchom jako administrator' grę odpaliłem i nawet grałem ;] A dzisiaj chciałem odpalić i właśnie pojawia się opisany wyżej problem wywalania do Windowsa. Jak sobie z tym poradzić?

 

Intel i5 750

MSI P55-GD65

GoodRAM 2x2GB 1600MHz

Asus Radeon HD5870

OCZ ModXStreme Pro 600W

no i Windows 7 64bit

 

A no i właśnie! Czy nie lepiej by mi było zmienić system na XP-ka 64bit? Bo mam 7 64bit tylko ze względu na to żeby mi całą pamięć RAM widział, a 7 bo... taka moda. Ale widzę ze jest XP-ek jest nieśmiertelny. Więc jeśli bym zmienił na XP 64bit to nie będę miał żadnego problemu z 'niewykorzystanym potencjałem sprzętu' ?

Czy 7 jest jakoś pomocna w grach czy jednak XP będzie lepszy?

 

Problem też mam z Painkillerem z Biedronki za dyche :D na XP grałem aż miło a na 7 w ogóle nie wykrywa płyty w napędzie - raz wykryło zaczęło się instalować, zatrzymało się na kilku procentach o już tak pozostało - program zaliczył zwieche.

 

Far Cry przy obecnej konfiguracji na najwyższych ustawieniach powinien chodzić płynnie prawda? A mam parę zastrzeżeń ;/

Winę cała zwalam na 'wspaniałego Windowsa 7'.

 

I właśnie w takim Far Cy 1 i 2 czy Crysis gdy zwiedzam świat i idę kilka metrów przede mną pojawia się trawa czy krzaczki a jeszcze jeden krok w tył tego nie było - dość 'chamsko' to wygląda. I jest to problem sprzętu? Czy gra jest tak (źle) napisana?

 

Brak dźwięku 5.1

Mam właśnie zestaw Logitecha X540 i na Windowsie 7 przy zintegrowanej karcie muzycznej i ustawieniu w opcjach zestawu 5.1 nie mam tego dźwięku. Wykonując test właśnie tam w sterownikach dźwięk pojawia się we wszystkich głośnikach ale podczas słuchania muzyki czy oglądania filmów jest to już tylko 2.1 - chyba że włożyłbym Sound Blaster Live 5.1 24bit, tylko nie wiem czy jest ona lepsza od dzisiejszych zintegrowanych kart.

 

Sterowniki

Co powinienem pobrać do: (na Windows 7 64bit)

Intel i5 750

MSI P55-GD65

Samsung S223C

Asus Radeon 5870

 

No i coś do poprawnego działania systemu i gier, Directx itp

Zainstalowałem kodeki: ACE Mega CoDecS Pack, a podczas ogladania filmu w KMPlayr raz ja jakiś czas następuje lekkie przycięcie filmu.

Share this post


Link to post
Share on other sites

1. Uruchom grę na prawach admina - pewnie starsza gra więc nie uznaje ograniczeń w W7.

2. Poczytaj o "XP Mode" czy jak się to tam zowie.

3. XP 64bit to taki średni pomysł.

4. Poszukaj tematu o grze i poczytaj. Podobnie poczytaj temat o W7.

  • Upvote 2

Share this post


Link to post
Share on other sites

1.Zrobiłem tak.

2.Próbowałem - nie przyniosło pożądanego skutku.

3.I know :(

4.A gdy zawodzą konwencjonalne metody? :(

 

Znalazłem takie oto coś 'kotor1-2_vista-w7_fixed_dll', fix który rzekomo naprawia opisany błąd - fakt, zadziałał wczoraj. Wkręciłem się troszkę w grę Very Happy (7 rano mnie zastała), przespałem się kilka godzin, chciałem zagrać i znów ten problem z wywalaniem do Windowsa! Nawet po ponownym wgraniu fixa. Dodam może tylko ze przy wywalaniu nie wyskakuje żaden błąd tylko gra jakby się minimalizowała a pod nią kryje sie tylko czarny ekran.

Share this post


Link to post
Share on other sites

win7 zostaw jako standard system + nowe gry...do starszych gier zainstaluj xp32bit jako drugi system...

 

chyba najbardziej racjonalne rozwiazanie moim zdaniem...niestety moja stycznosc z 7 znikoma wrecz mozna powiedziec ze zerowa :) wiec tu nic nie wymysle :)

Edited by adas123
  • Upvote 1

Share this post


Link to post
Share on other sites

Ja gralem w kotora na W7 (jeszcze RC) oraz Viscie i tez mialem problem (ale u mnie to program sie wieszal). Po wielu zabawach udalo mi sie ustawic ktorys z trybow zgdnosci i latalo pozniej dobrze (ustaw uruchom program z prawami admina + wylacz kompozycje pulpitu/wizualne + wylacz skalowanie do wysokiej rozgdzielczosci). A co do ktorego trybu zgodnosci - to probuj :P

 

Po za tym wyglada jakby cos mialo "czkawke" w twoim kompie. Wgraj najnowsze drivery od ati i moze podkrec procka troche, aby sprawdzic czy objawy sie nie zmniejsza :)

Share this post


Link to post
Share on other sites

Heh. Z kotorem ciekawa sprawa, bo masa ludzi ma problem na W7.

Chciałem sobie wczoraj przejść po raz kolejny (na xp x64 też nie dało rady i grałem na 32bit), zainstalowałem a tu zonk. Po godzinie zabaw z szukaniem prawdopodobnego rozwiązania odpuściłem.

Dzisiaj spróbuję jeszcze się pobawić. Jak mi sie uda, to opiszę co i jak ustawić.

 

.:.: ed :.:.

do tej pory fail

 

.:.:ed2:.:.

Do tej pory pod win7:

  • podmieniona dll-ka zgodnie z info z gizkateam,
  • gra po patchu,
  • całość przeinstalowana (setup też jako winxp na prawach admina),
  • świeże sterowniki
  • zabawa rivaTuner i opcjami openGL (znalezione na jakimś innym forum, gdzie też mieli problemy z kotorem)
Wszystkie powyższe stosowane w różnej kolejności i różnych konfiguracjach, gra zainstalowana łącznie trzy razy, komp restartowany też kilkakrotnie, przy okazji dłubanie w rejestrze, bo instalator za którymś razem usilnie chciał odinstalowywać już odinstalowaną grę (nawet po restarcie).

Nie mam już siły. Idę na laptoka, gdzie jest xp x86, więc na 100% będzie działać poprawnie bez zbędnych cudów.

Edited by m4r

Share this post


Link to post
Share on other sites

Stary, próbowałem ze cztery różne .exe. Nawet już w końcu (o tym nie pisałem) zrzucałem .dll wypakowane ze sterów nvidii (taki trick działał dla dll-ek openGL dla nowszych ATI (i na nich podobno po takim "unlocku" openGL działa kotor 1 i 2). Ofc epic fail, czy jak to tam zwał.

Może w końcu się ktoś zlituje i wypuści jakiegoś patcha. Oby. Chociaż, dopóki mam lapka, jakoś sobie poradzę, więc na ten moment kończę zabawę z próbami uruchomienia kotora u siebie. Może ktoś będzie miał więcej szczęścia.

 

.:.:Ed:.:.

Aaa.. oczywiście zapomniałem napisać. U mnie kotor nie pokazuje nawet logosów Bioware i Lucas Arts. Po prostu - dwuklik, pół sekundy i info o błędzie. Ot, szaleństwo w czystej postaci.

Edited by m4r

Share this post


Link to post
Share on other sites

Sam gralem w dwojke i tez bez problemow dzialac nie chciala, ostatecznie jednak odpalila. Z jedynka pewnie gorzej, ale probowalbym pomeczyc wirtualizacje. XP Mode co prawda sie do tego nie nadaje ze wzgledu na brak akceleracji sprzetowej dla goscia i moze wlasnie dlatego Ci gra nie ruszyla. VMWare jednak jest w stanie zaemulowac karte zgodna z dx9.0c wiec moze dalo by rade.

Share this post


Link to post
Share on other sites

moze to tylko na 64 bitach sie dzieje, a na 32 lata juz dobrze

 

edit: Dzisiaj bedac na lapku braciaka z w7 x64 (chyba professional) po zainstalowaniu kotora, bez zadnych problemow ladnie sie odpalil. Pozniej podmienilem exe, aby mi zabezpieczenie ciagle plyty nie orcowalo w napedzie. Co jakis czas gra sie wywala ale to juz chyba wina cracka no-cd. W lapku jest karta nvidii (gf 9600m gt), wiec mozliwe ze to wina sterownikow ati, ze kotor sie wykrzacza juz przy samym starcie.

Edited by Quave

Share this post


Link to post
Share on other sites

Tak jak myslalem, winne sa sterowniki xP Po odinstalowaniu driverow 10.2 i zainstalowaniu najnowszych 10.3 wszystko smiga jak nalezy :) (mam nadzieje ze sie nie wysypie w najblizszym czasie :lol: )

 

edit: kilka godzin katowania w kotor'a i bez zadnej zwiechy :lol2:

Edited by Quave

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...


Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.