Jump to content
stivo

Problemy z dyskiem 2.5"

Recommended Posts

Cześć.

 

Dostałem od znajomego laptopa Fujitsu - Siemens (Amilo_Xa BS037), bym przyjrzał się co mu jest. Pierwsze objawy to baaaardzo długie ładowanie się systemu. Po załadowaniu się takiego poprzecznego (na całą szerokość ekranu) paska, pojawiał się problem z brakiem lub uszkodzeniem pliku ntfs.sys

 

W sumie to nie wiedziałem nawet jaki tam był system, ale po naklejce licencyjnej wywnioskowałem, że to Vista Home Premium, więc włożyłem płytkę z instalatorem i wybrałem Napraw. Jednak instalator nie widział dysku/partycji z systemem. Podobnie z oryginalną płytką Recovery, która była w zestawie.

 

Podłączyłem dysk u siebie (długi scandisk przy uruchomieniu, trochę błędów) i widziałem dane na nim, jednak partycja systemowa miała oznaki uszkodzenia, bo pliki nie chciały się kopiować czy były uszkodzone. Jednak brakowało mi na niej folderu Users, który jest w Viście, więc pomyślałem, ze to XP. Zamontowałem dysk z powrotem do lapka i wrzuciłem płytkę z XP PRO SP3. Wg instrukcji ze strony MS nt. tego błędu przekopiowałem plik z płytki na dysk. Jednak zamiast błędy ntfs.sys zaczął pojawiać się BSOD i szybki restart, wiec nawet nie wiem co na nim było.

 

Podłączyłem dysk do siebie jeszcze raz i za pomocą programu Unstoppable Copier chciałem zrobić backup ważnych plików z Documents and Settings. To tylko w sumie 8GB danych, a trwało i trwało (grubo ponad 24h). Dzisiaj w pewnym momencie program się zawiesił, a system tak zamulił, że musiałem zrestartować kompa. Teraz mój system wstaje zdecydowanie dłużej.. Może to wina tego dysku.. Jednak w samym systemie nie widać już partycji dyskowych.. I tu zwracam się do Was z prośbą o pomoc w odzyskaniu danych (bo nie wszystko udało się skopiować) i potem ewentualnie doradzenie jaki dysk dodatkowo kupić, bo właściciel notebooka zdecydował, że skoro takie rzeczy się dzieją, to na nowy dysk może wyłożyć kasę. Myślę, że za 200-250PLN chyba coś dostanę, tylko co?

 

Z góry dzięki za pomoc.

Share this post


Link to post
Share on other sites

Ja obstawiam na uszkodzenie sektorów - dlatego system może się długo uruchamiać (bo system nie może odczytać plików w uszkodzonych sektorach) i mogą być problemy z odzyskaniem danych (jw. - dane znajdują się w uszkodzonych sektorach). Na początek spróbuj skanu programikiem MHDD, a do odzyskania plików wypróbuj GetDataBack NTFS - mi pomógł ostatnio na uszkodzonej czterdziestce, gdy inne programy zawodziły. Może i u Ciebie da radę.

Share this post


Link to post
Share on other sites

Z opisu można wnioskować że stan dysku jest w bardzo złym stanie. Więc zanim zaczął bym przywracać dane wykonałbym obraz całego dysku (z załączoną opcją kopiowania danych sektor po sektorze) z której chcesz odzyskać dane. Następnie proces odzyskiwania przeprowadzasz na wykonanym obrazie.

 

Do odzyskiwania danych użył bym programu Recuva (podobno bardzo dobry i do tego darmowy).

 

Do stworzenia obrazu dysku użyj Acronisa True Image, lub Norton Ghosta.

 

Nauczka na przyszłość, elektronika jest zawodna a ważnych danych wykonuje się kopie! Możesz powtórzyć to znajomemu.

Edited by KoVol

Share this post


Link to post
Share on other sites

Dzisiaj dysk w sumie pracuje "normalnie" pod moim systemem i odzyskiwanie plików trwa, ale po kolei.

 

@Marians:

1. MHDD nie chce się bootować ani na lapku, ani na moim sprzecie :unsure:

2. GetDataBack for NTFS - ok działa, ale bez licencji nie skopiuje mi danych, chyba, że jakaś wersja tego nie wymaga?

 

@Kovol:

1. Próbowałem zrobić obraz za pomocą Easeus ToDo Backup, który u mnie radzi sobie świetnie, a z tym dyskiem zatrzymywał się już na etapie sprawdzania..

2. Recuva raczej nie jest tu potrzebna, bo pliki nie są usunięte (w każdym razie Unstoppable Copier działa sobie)

3. Backup ważnych danych? Wiesz są dwa rodzaje ludzi: Ci co robią backupy i Ci co zaczną je robić ;)

 

 

Ok, odzyskiwanie w sumie można pominąć. Ale problem jest teraz z zainstalowaniem Windowsa. Jest nowy dysk od WD (320GB, blue) i raz udało mi się w instalatorze podzielić go na partycje, poszło dalej, ale w pewnym momencie wypluł, że potrzebuje płyty z systemem XP SP3 Pro w napędzie, a taka była włożona (z MSDNAA). Zrobiłem restart, instalator poszedł dalej normalnie, ale wywalił BSODa..

 

Wrzuciłem Hiren's Boot, sprawdziłem pamięci Memtestem i przeszły bez problemu. Potem Gparted i od nowa ustawiłem partycje. Teraz jakąkolwiek płytkę instalacyjną bym nie wkładał, to po pierwszym etapie kopiowania plików dostaję BSOD 0x0000007E. Nie wiem co z tym począć?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.