Jump to content
Sign in to follow this  
Tormen1

Ubuntu - czarny ekran podczas instalacji

Recommended Posts

Witam, nie mogę nigdzie znaleźć odpowiedzi na mój problem. Otóż na dysku ssd mam Windows 7, na drugim dysku HDD 2TB mam dane, ze tego właśnie dysku utworzyłem partycję 100GB co by sobie na niej zainstalować Ubuntu 14.04.3 LTS, nie chciałem się bawić w żadne wirtualne maszyny. Utworzyłem na pendrive system tym programem: YUMI-2.0.1.8. Odpalam boot menu i wybieram pendrive z listy, uruchamia się menu czy instalować, czy wypróbować ubuntu, i pozostałe opcje (help, advance…). No to daje instaluj, coś tam miga i czarny ekran, monitor szuka po sygnałach, ale nic nie może znaleźć i wyświetlić. Jestem pewien, że instalator się uruchomił gdyż słychać charakterystyczne bębny podczas uruchomienia instalatora. Na starym kompie zainstalowałem bez problemu, ale chciałbym na nowym mieć obok Windows 7. Mój sprzęt to Core i7-4790K, MSI Z97 Gaming 5, no i MSI Geforce 970GTX.

Share this post


Link to post
Share on other sites

Prawdopodobnie chodzi tu o sterownik do karty graficznej. Kernel wykrywa kartę Nvidii i próbuje załadować sterownik Nouveau. Niestety GTX 970 nie jest (jeszcze) obsługiwana przez Nouveau.

 

Spróbuj podłączyć monitor pod wyjście na płycie głównej, tak żeby instalacja przeszła na karcie zintegrowanej, albo w GRUB-ie (tam gdzie wybierasz czy wypróbować czy zainstalować system) wybierz interesującą Cię pozycję, naciśnij "e" i do opcji kernela dopisz "nomodeset" (bez cudzysłowu) i naciśnij F10 żeby uruchomić system/instalator ze zmodyfikowanym parametrem uruchamiania.

 

Opcja z instalacją na zintegrowanej karcie jest łatwiejsza, bo po instalacji system normalnie się uruchomi w trybie graficznym i bez problemów będziesz mógł zainstalować własnościowe sterowniki to GPU. IMO warto dodać repozytorium PPA dla sterów Nvidii i używać najnowszych dostępnych.

 

PS: Witaj w krainie pingwina, gdzie kombinowanie nigdy się nie kończy. ;)

Share this post


Link to post
Share on other sites

Wciskam "e" ale nic się nie dzieje to znaczy nie ma nigdzie miejsca co by wpisać "nomodeset". A z tym drugim rozwiązaniem to się okazało, że ze zintegrowanej obraz nie wyświetla też szuka po sygnałach. Muszę jakoś w biosie uruchomić tą zintegrowaną czy co?

Podłączyłem kartę ze starego kompa i też nie wyświetla obrazu, co jest ta 970 wszystko mi blokuje czy co? :D

Wyjąłem 970 i poszedł obraz z zintegrowanej, czemu mi 970 blokuje obraz ze zintegrowanej? Przecież nie będę wkładał i wyjmował karty żeby z innego systemu sobie skorzystać.

Edited by Tormen1

Share this post


Link to post
Share on other sites

http://www.ubuntu-pomoc.org/ubuntu-11-04-czarny-ekran-podczas-uruchamiania-systemu/

 

http://ubuntuforums.org/showthread.php?t=1613132poprzeglądaj

 

http://www.zsgostyn.pl/plik/ubuntu_14.04.pdf

Podpunkt 2.10.1

 

2.10.1 Po wybraniu opcji „Wypróbuj Ubuntu bez instalacji” lub „Instaluj Ubuntu”
mam tylko czarny ekran
Po pierwsze, nie spiesz się, wczytanie wszystkich danych z nośnika instalacyjnego trwa dłuższą
chwilę. Jeżeli nic się nie dzieje dłużej, niż 2 – 3 minuty, to zrestartuj komputer i uruchom instalator
Ubuntu jeszcze raz. W przypadku instalatora BIOS (fioletowe tło) po wybraniu języka wciśnij F6
(inne opcje), zaznacz opcję „nomodeset” klawiszem ENTER , wyjdź z menu klawiszem Esc i uruchom
instalator. Opcja „acpi=off” też może być pomocna.

Edited by NostradamuSek

Share this post


Link to post
Share on other sites

Teraz już wiem, jak wejść w to menu... Bo mam na płycie i na pendrive ubuntu, z płyty to jak jest fioletowe tło wciskam obojętnie co i mam te menu z F6 i innymi opcjami, a jak z pendrive to mam czarne, do góry pisze ubuntu i mam wypróbuj, zainstaluj, zaawansowane, uruchom coś tam z dyski i help i w tym menu to nie mogę nic zrobić, wciskam "e" to nic się nie dzieje i ogólnie nie wiem gdzie parametr„nomodeset" wpisać. Ale i tak jak mam z płyty, wybieram język, F6 inne opcje instalacji, zaznaczam  „nomodeset” i „acpi=off” a i tak czarne tło, na 100% instalator jest włączony bo podczas jego uruchomienia słychać te charakterystyczne bębny, dźwięk, ale obrazu jak nie było tak nie ma. Chyba się nie da, jakieś bydle mi pożałowało tego ubuntu.

Interesujące jest też to że mając karte 970GTX włożoną w płytę to zintegrowana nie działa, tak to sobie bym przecież kabelki tylko przełączył.

Edited by Tormen1

Share this post


Link to post
Share on other sites

Obecne płyty same odłączają integrę kiedy wykryją dodatkowe GPU. Wejdź do BIOS-u/UEFI i zobacz czy zintegrowana karta jest włączona. Poszukaj też opcji odpowiadającej za to na którym wejściu ma być wyświetlany obraz w czasie uruchamiania komputera.

Share this post


Link to post
Share on other sites

Szukałem, ale nic nie znalazłem, będę próbował dalej. W biosie znalazłem tylko Integrated Grphics Configuration w nim Initiate Graphic Adapter na PEG mogę przełączyć na IGD, nie wiem co to jest, i jeszcze IGD Multi-Monior na Dispabled. Gdzieś czytałem że zintegrowana nie działa gdy w slocie jest karta i nie ma możliwości by działała, czy to prawda?

A wracając do linuxa... może inna dystrybucja co nie korzysta z tego interfejsu graficznego. Z Debianem też są takie problemy? 

Share this post


Link to post
Share on other sites

Mam GTX 970 i Linux Mint bez problemu dał się zainstalować. Potem tylko dodałem PPA ze sterownikami Nvidii i wszystko ładnie działa. No i wolę Cinnamon niż Unity.

 

IGD to właśnie karta zintegrowana: Integrated Graphics Device.

Edited by CarrionCrow

Share this post


Link to post
Share on other sites

I nie musiałeś żadnych cudów wyczyniać? Będzie chwila to sprawdzę to. 

A i jak zrobić żeby przy starcie kompa wybierać między Windows a linux?

Edited by Tormen1

Share this post


Link to post
Share on other sites

Nic nie musiałem cudować. ;) U mnie instalator wykrył Windowsa na dysku i dodał odpowiednią pozycję do GRUB-a (programu rozruchowego).

Share this post


Link to post
Share on other sites

No u mnie instalator windowsa nie wykrył ;)

A nie już mam. I jak te sterowniki mówisz dodałeś?

Dobra, też mam. Tylko jak chce włączyć window7 to przestaje działać myszka i klawiatura.

I nie mogę z windowsa 7 korzystać, tak że dalej d**a, ale przynajmniej jakieś postępy są;)

Edited by Tormen1

Share this post


Link to post
Share on other sites

Dobra, chyba mam. Metodą prób i błędów, myślę, że chyba udało się ładnie wszystko zrobić, z płyty dołączonej do płyty głównej zainstalowałem wszystkie sterowniki, a samego linuxa zainstalowałem na osobnym dysku, nie partycji. Do tego partycje z Windows 7 przekonwertowałem na MBR.

Share this post


Link to post
Share on other sites

U siebie zrobiłem tak:

1. Sformatowane wszystkie dyski

2. Podczas instalacji Windowsa robię to 

 

na partycji gdzie będzie windows.

3. Zainstalowałem wszystkie sterowniki z płyty dołączonej do płyty głównej, można sprawdzić w menadżerze urządzeń, czy nie ma czasem znaków zapytania przy czymś.

4. Ogólnie instalacja wszystkich sterowników na komputerze do wszystkich urządzeń.

5. Z pendrive lub płyty instalacja linuxa na oddzielnym dysku nie partycji (ja sobie po prostu dysk ze starego kompa podłączyłem i na nim mam linuxa) 

Tak zrobiłem i u mnie wszystko jak na razie działa. Zainstalowany  Linux Mint, bo ubuntu nie chciał współpracować na 970GTX.

Edited by Tormen1

Share this post


Link to post
Share on other sites

w 15.10 instalator daje radę z GTX 970, btw właśnie wyszła wersja oficjalna 15.10

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.