Skocz do zawartości
FilippoEnigma

Nie mogę zainstalować żadnej dystrybucji linuxa

Rekomendowane odpowiedzi

Dzień dobry. Miałem sporo dystrybucji linuxa i skakałem z jednej na drugą, w pewnym momencie przestały się instalować, proszę o pomoc.
i5 4460
h97 hd3
gtx 970
1tb hdd
256 gb ssd
8gb
win 10
win 7
Dodaję link pokazujący jak to dokładnie wygląda: 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

A próbowałeś bootować pendrive bez uefi? Neon/Ubuntu/Netrunner mają taki sobie support EFI boot

 

https://community.kde.org/Neon/InstallableImages#UEFI_Support

tu looknij

https://forum.kde.org/viewtopic.php?f=309&t=136960

 

A tu ogólne info, dlaczego warto nie używać UEFI producenta sprzętu (tak długo, jak się da)

https://libreboot.org/faq.html

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Sandisk jest w porcie USB 3.0 podczas instalacji? Jeżeli tak, możesz go włożyć do USB 2.0?

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Istnieje szansa, że notebook ma 2xGPU (iGPU + dGPU) i sterownik pod win dokonał zmiany tak, że teraz dGPU jest domyślnie inicjowaną przez bios podczas bootowania? Sprawdź w bios czy jest taka opcja, a jeżeli nie ma, to sprawdź pod win. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Jak wcześniej się bawił i instalował Linuxy to zapewne Secure Boot ma wyłączone .

 

Tym bardziej że ma Win 7 i Win 10 na dysku .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Ale to komputer, a karta graficzna gtx 970 jest podpięta pod monitor.

 

Nie rozumiem? Notebooki mają często dwie karty graficzne (Twój z tego co teraz widzę ma GTX 970), współdzielące wyjścia. Standardów przełączania tego jest kilka, zaimplementowane pod linux są różnie, ale w większości przypadków jest to problematyczne. Jeżeli notebook ma opcję stałego przełączania działającego GPU i jako główna karta jest ustawiona nVidia, to instalator Linux może mieć problem, jeżeli otwarty sterownik nie potrafi obsłużyć grafiki. Chodzi o podobne ustawienia:

bios-graphics.png

 

jakkolwiek w notebooku niekoniecznie w ogóle są.

Jeżeli to zewnętrzne GPU (wątpie), to je odłącz i sprawdź bez niego. 

 

Faktycznie, sugestia wyłączenia secure boot nie jest od rzeczy, ale samo się raczej nie włączyło, jeżeli nie grzebałeś w BIOS lub go nie aktualizowałeś, a ustawienia grafiki mógł zmienić sterownik windowsowy. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

@Dijkstra

 

A zwróciłeś uwagę na pierwszego posta , konfiguracja zdecydowanie sugeruje stacjonarkę niż lapka , nie widziałem jeszcze lapka z I5 4460 .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Tak, acz z pewnym opóźnieniem, ale i tak totalnie nic mi to nie powiedziało, bo  od dłuższego czasu nie interesuje mnie, jak intel czy amd oznaczają swoje procesory i czy są  destopowe czy nie. Rozróżniam CPU serwerowe i nie i tyle. Ale to totalnie nic nie zmienia. Instalatory graficzne (np. Ubiquity, którego używa sporo distro) nie zawsze są w stanie poprawnie działać, jeżeli pierwszą inicjowaną kartą jest dGPU/PCIE. Sprawdzenie tego nie kosztuje dużo, a to na filmie wyglada jak jakiś hardware problem, bo instalator restartuje kompa i totalnie nic nie wyświetla. Na secure boot mi to nie wygląda, bo bądź co bądź instalator KDE Neon się uruchomił do momentu wyświetlenia menu tekstowego wyboru trybu instalacji - wywalił się kawałek dalej, podejrzewam, że przy próbie przejścia w tryb graficzny.

 

PS. Spróbowałbym jakiegoś distro z instalatorem czysto tekstowym (debian, ubuntu serwer), to może przynajmniej w konsoli wyświetlony zostanie jakiś błąd, lub - w przypadku distro Ubuntopodobnego, które pozwala na zrobienie pendrive z trwałym cache użytkownika - przejrzenie loga instalatora, który powinien się znaleźć wówczas na pendrive po nieudanej instalacji. 

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Nie rozumiem troszkę o co chodzi z tą kartą graficzną więc wrzucam zdjęcia biosu.

https://zapodaj.net/bb0ece00f43ff.jpg.html

https://zapodaj.net/8fe724c7c40e1.jpg.html


Nie rozumiem troszkę o co chodzi z tą kartą graficzną więc wrzucam zdjęcia biosu.

https://zapodaj.net/bb0ece00f43ff.jpg.html

https://zapodaj.net/8fe724c7c40e1.jpg.html

Już ściągam ubuntu serwer


Nie rozumiem troszkę o co chodzi z tą kartą graficzną więc wrzucam zdjęcia biosu.

https://zapodaj.net/bb0ece00f43ff.jpg.html

https://zapodaj.net/8fe724c7c40e1.jpg.html


Już ściągam ubuntu serwer

Włączyłem instalkę ubuntu serwer. Wszystko działało. Wychodzi na to, że to karta graficzna. Teraz proszę o pomoc z naprawą tego problemu.

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Karta pod Windowsem działa normalnie ?

 

Czy wywala reset sterownika lub coś innego .

 

Spróbuj zainstalować linuxa który wcześniej u ciebie działał, ew. odpal wersje Live CD - zobaczymy czy tam GUI będzie działać .

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Mint używa tego samego instalatora, co ubuntu (ubiquity), więc pewnie kwestia przekazania jakiegoś parametru kernelowi z gruba. Sprawdzę w wolnej chwili. Jaką wersję instalowałeś, najlepiej które iso. 

  • Upvote 2

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach

Przełącz w biosie kartę na IGFX i przełóż kabel do złącza w płycie głównej. Jeśli to nie pomoże, to wyjmij ze złącza kartę i sprawdź ponownie.

  • Upvote 1

Udostępnij tego posta


Odnośnik do posta
Udostępnij na innych stronach
Gość
Komentujesz jako gość. Jeśli posiadasz konto, zaloguj się.
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Przywróć formatowanie

  Maksymalnie dozwolone są tylko 75 emotikony.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

Ładowanie

Aktualności

Artykuły



×