Jump to content
Guest toom18

Nie mogę zainstalować żadnego Linuxa

Recommended Posts

Guest toom18

Witam.
Mam problem z PC potrzebuje zainstalować jakiegoś Linuxa i z tym jest problem albo czarny ekran albo jakieś dziwne błędy, dodanie nouveau.modeset=0 nic nie daje.

Mam takie coś, i wtedy to już nawet reset nie pomaga trzeba trzymać przycisk zasilania aż się komp wyłączy.
d242b49bb940.jpg

Share this post


Link to post
Share on other sites

Napisz, może na początek:

1. Jaką dystrybucje instalujesz?
2. Na jakim sprzęcie ją instalujesz?
3. Na jakim etapie instalacji występuje problem?

 

Share this post


Link to post
Share on other sites

Ten PC to starszy sprzęt czy coś nowego z uefi i win 8.x lub wyżej ?

Jak masz nowy sprzęt z UEFI to sprawdź opcje dot. secure boot .

OS instalujesz z płyty czy pendriva ?

Share this post


Link to post
Share on other sites
Guest toom18

To tak. Sprzęt to

i7 7700

Asrock z270 Taichi 

RAM 16 GB DDR 4 G. Skill 3200 MHz 

SSD 960 Pro 512 i Crucial mx200 250 GB 

HDD 2tb Toshiba p300 

Grafa dzidunio Gtx 970 

Zasilacz xfx 650w 

Buda nie ważne xD 

A próbuje Ubuntu 16.04,16.10, 17.04 

OPENSUSE nie pamiętam jakie ale najnowsze stabilne.

Jak i minta i inne we wszystkich to samo.

A po dodaniu nomodeset jak i  nouveau.modeset=0

Oczywiście w odpowiedni miejscach mam takie coś 

 

20180223_222141.jpg

20180223_222141.jpg

Share this post


Link to post
Share on other sites

1.Windows zainstalował się na tym poprawnie?

2. Memtest86 coś zwraca?

3. Procesor, RAM był podkręcony? Sprawdź, czy problem występuje również po przywróceniu ustawień BIOS do wartości domyślnych.

Share this post


Link to post
Share on other sites

Windows działa w Memteście nic nie wykazało wiec ram oki i nic nie jest podkręcone. z tym że pamięć jest 3200 ale nie działa XMP ale to standard, znaczy działal XMP ale pc nie wstaje 3 razy i przywraca domyślne ustawienia. Próbowałem przywracać domyślne ale nic nie daje

Share this post


Link to post
Share on other sites

To wygląda jak nie supportowany CPU microcode lub inny problem z firmware (bios/uefi). Masz możliwość dokonać upgrade?

Jeżeli nie:
- spróbuj dokonać instalacji spod windows (kilka distro z ubuntu na czele na to pozwala)
- ręczne dłubanie: pobranie ze strony intela paczki z microcode i załadowanie jej podczas bootowania ręcznie z grub'a
doku arch'a, ale praktycznie tak samo wygląda to na każdym distro. 
https://wiki.archlinux.org/index.php/microcode

Acz to dziwne... procek ma jakoś około roku, ucode powinien  być w instalatorach nowszych distro.

Share this post


Link to post
Share on other sites
Guest Toom18

UEFI mam w najnowszej wersji, próbowałem już różnych wersji i niestety na każdej to samo. 

Share this post


Link to post
Share on other sites

Jeżeli możesz, zmień na BIOS albo spróbuj instalacji spod Windows. 

Ewentualnie czasowo wyłącz najpierw efi secure boot, jeżeli jest włączone.

Share this post


Link to post
Share on other sites

Spróbuj zainstalować jakieś distro ze starszym kernelem 3.19 np.  Ubuntu 14 ew 15

Memtesta jak długo maglowałeś?

Share this post


Link to post
Share on other sites

Mem test leciał przez 18h ale na obydwu kościach naraz
Próbowałem zainstalować Ubuntu przez WUBI niby się pobrało wyskoczyło czy chcesz uruchomić ponownie teraz czy później dałem teraz a i tak uruchomił się Windows xD wiec wiozłem ten plik iso co pobrało WUBI i mam takie coś
2d70eadc2b98.jpg
fadf5a8244ed.jpg

a tu ustawienie UEFI

eb229c97c793.jpgfab7e3360a1c.jpg

Na dysku zewnętrznym znalazłem linuxmint-18.1-kde-64bit
Bez podania nomodeset nic z tego po podaniu nomodeset
2eae5a2915d0.jpg
a po odłączeniu dysków sata

5fe8b95d48ae.jpg

To co jest z Ubuntu ?

Z nomodeset i bez dysków sata i Ubuntu 17.04 wstaje 

673bb4c74e3c.jpg

A ja głupi walczę z tym już kilka miesięcy... 

No dobra a co może być tego przyczyną? 

Edited by toom18
Mint wstaje xD i Ubuntu z nomodeset i bez sata też

Share this post


Link to post
Share on other sites

Ubuntu i mint to to samo w sensie kernel i większość repozytoriów. 

Jeżeli wstaje bez sata, to coś z którymś driverem chipsetu - najpewniej któryś z problemów ogólnie dotyczących chipsetu:
https://ubuntuforums.org/showthread.php?t=2374620

Możesz teraz spróbować pod ubuntu doinstalować kernel 4.14 lub 4.15 i spróbować, czy z nim wstanie przy włączonym SATA. 

Share this post


Link to post
Share on other sites

Problem może być z UEFI i gpl mbr dysku, instaluj też z płytki cd.

Nie będziesz miał problemu z penem czy jest w UEFI, i jeszcze po instalacji może ci startować windows, a nie program rozruchowy linuxa.

Zmień ustawianie w biosie z której partycji ma uruchamiać się komputer.

Edited by sas991

Share this post


Link to post
Share on other sites
41 minut temu, ciekawa_osoba napisał:

Fedora bez problemu radzi sobie z UEFI,  spróbuj ją zainstalować.

Użytkowniku Downnote. Co takiego złego napisałem?

  • Downvote 1

Share this post


Link to post
Share on other sites
6 godzin temu, ciekawa_osoba napisał:

Użytkowniku Downnote. Co takiego złego napisałem?

Raczej to, że odkopałeś taki wątek, że złoty szpadel się należy.

Share this post


Link to post
Share on other sites
8 minut temu, Zgreed66 napisał:

Raczej to, że odkopałeś taki wątek, że złoty szpadel się należy.

Długo nie kopałem, był na pierwszej stronie, jeden z pierwszych wątków. 

 

Aha, bardzo miło witacie nowych użytkowników. Oczywiście to żart. 

Edited by ciekawa_osoba

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.