Skocz do zawartości
Kidzi1

Windows 7 i dźwięk 5.1 z Netflixa

Rekomendowane odpowiedzi

Witam

Niedawno na skutek szeregu usprawnień domowych komputerów po najmłodszym z synów ostał mi się nieco leciwy konfig, z którego postanowiłem sklecić podtelewizorowe centrum rozrywki ;-)

Jest to płyta na s775 z przerobionym Xeonem X5450 (4 x 3.0 GHz), 4GB DDR3, Radeon HD 5770 i 2x1TB HDD archiwum filmowego. Kiedyś miałem na tym W10 postawione, ale już od jakiegoś czasu ponoć te Xeony nie są wspierane, więc zostaje mi Windows 7 lub jakiś linux. Mam do tego podpięty optykiem amplituner Onkyo i TV po HDMI. Filmy z dysku rzecz jasna działają pięknie z dźwiękiem 5.1, problemem natomiast jest Netflix. Z tego, co wyczytałem, dźwięk 5.1 obsługuje jedynie aplikacja pod W10. To samo się tyczy rozdzielczości fullHD. Rozdzielczość da się obejść, jest plugin do Chrome, który zmienia identyfikator przeglądarki i działa fullHD. Z dźwiękiem natomiast jest problem.

Czy ktoś zna jakiś sposób wypuszczenia dźwięku 5.1 z netflixa poza aplikacjądla Win8/10 ?

Nie upieram się przy Win7, może być jakiś linux, kiedyś używałem XBMC, w sumie należało by tą opcję przetestować ...

Będę wdzięczny za wszelkie informacje

Edytowane przez Kidzi1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Kodi obsługiwał nieoficjalną wtyczkę do netflix'a od wersji 18, ale nigdy nie testowałem - siedzę cały czas na 17, bo mam stare ubuntu i nie chce mi się aktualizować. Windows jako OS pod MediaCenter/HTPC odpuściłem już dawno temu (w zasadzie, to ogólnie odpuściłem), bo zawsze znajdował sposób, żeby wywalić jakiegoś popupa na interface Kodi, przerwać odtwarzanie albo się wywalić. 

Spróbuj pobawić się Androidem i/lub AndroidTV x86 + apką netflix'a, prawdopodobnie najmniej nerwów stracisz... ogólnie z androidem x86 nigdy nie miałem większych problemów, a używałem go dość długo na notebooku (jeden z moich pracodawców miał VPN, który działa tylko na Windows, IOS lub Android, a ja zasadniczo od dawna raczej linuxowy jestem). Instaluje się dość łatwo, więc po prostu zainstaluj, sprawdź, czy łyknie Twoją kartę dźwiękową/passthrouch/DAC, wrzuć apkę Netflix i sprawdź, czy działa. Będziesz musiał poczytać, jak zainstalować Gapps, a przynajmniej GoogleStore, bo w czystym x86 ich raczej na pewno nie będzie (licencja Androida). Albo samo APK z neta, ale trzeba byłoby zaufane źródło znaleźć.

Natomiast... odpowiedz sobie, czy warto.  Chromecasta lub jakegoś STB z Androidem kupisz <200zł, a setup z Xeonem będzie żarł prąd jak wściekły i pewnie ani piękny, ani cichy, ani wygodny nie będzie. 
https://www.komputronik.pl/product/501134/savio-smart-tv-box-basic-one.html

  • Like 1
  • Upvote 1
  • Downvote 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dzięki za wskazówki, kiedyś się nosiłem z Androidem x86 i trzeba będzie odświeżyć.

 

Natomiast czy warto ? Zawsze warto ! ;-) Gdzie ja Chromecasta otworzę, wentylatorki przeczyszczę, pastę wymienię ... :P

 

Jeszcze wyczytałem, że przy takich buildach na Xeonie sporo zależy od biosu płyty głównej i poprawnie zaimplementowanych mikrokodach, muszę w tym pogrzebać, bo na sieci dużo jest przykładów z działającym Win10 na takich Xeonach.

Dzięki jeszcze raz za pomoc

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

A kto Ci powiedział, że Windows 10 nie pójdzie?

Dla wersji Windows 10 32bit, potrzeba sprzętu procesora wspierającego instrukcje PAE, NX i SSE2.
Dla wersji Windows 10 64-bit musimy mieć dodatkowo wsparcie instrukcji CMPXCHG16b, PrefetchW i LAHF/SAHF.

Jedyne czego nie ma Xeon X5450 to PrefetchW.

Robi się to tak. Wkładasz jakikolwiek CPU do swojej płyty, byle miał to co wyżej, sprawdzisz na CPU World. Instalujesz Win 10 64bit, a później podmieniasz na swój CPU i wszystko działa.

Ze sklepu Microsoft pod Windows 10 instalujesz apke Netflix i wszystko hula :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Powiedział mi to instalator windows - przy próbie instalacji gołego systemu trochę owijał w bawełnę i się wieszał w pewnym momencie instalacji, natomiast przy próbie apgrejdu z Win7 obwieścił mi to wprost - Twój procesor nie jest obsługiwany :

 

41a6e12b-56f1-46c2-9311-e569da083886

 

Ze wstawieniem czegokolwiek w miejsce Xeona może być problem - mam jedynie Pentiuma E5300, z tego co widzę, też nie obsługuje PrefetchW.

Pokombinuję jeszcze z innym biosem.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

E5300 na bank by działał. Instalowałem win10 64 bit na Celku E3300.

Tylko nie rób instalacji poprzez aktualizację, tylko zainstaluj z MS Media creation tool z USB. Tylko pamiętaj, aby plik media creation tool był na USB i odpalasz ściąganie z USB, a nie dysku komputera.

Pewnie na twoim Xeonie też pójdzie. Tylko instalka z USB od początku.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Właśnie spróbowałem kolejny raz z poziomu Windows 7 i oto, co wywala :

procek.jpg.8e4afd00bb933e0d1f5cb6641d0b3cbd.jpg

 

Wydaje mi się, że problem jest jednak z samą identyfikacją procka - CPU-Z pokazuje go w nagłówku jako E5450, a chwilę później jako X5450

 

procek2.jpg.adddc23e9bb54e9cdc36c3e58c0f678f.jpg

 

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Daj sobie spokój z poziomu Windows 7. Instaluj z USB z Media Creation Tool od początku. Chyba, że ten modowany bios coś namieszał. Nie wiem jak na tym Xeonie, ale na E5300 musi iść (przynajmniej z oryginalnym nie modownym biosem). Pisałem Ci przecież, że instalowałem na Celku E3300, a to to samo co Pentium E5300.

  • Upvote 1

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Postanowiłem sobie zostawić czystą instalację z USB na sam koniec, jak już wszystko zawiedzie, bo mam też równolegle do Win7 zainstalowanego Minta.

A propos sugestii Dijkstra - spróbowałem też Kodi, ale zdaje się nie ma już do niego wtyczki Netflixa, przynajmniej z poiomu samego programu nie znalazłem. A poza tym przy konfiguracji wyjścia dźwiękowego programu okazało się, że sterownik do karty dźwiękowej Minta obsługuje SPD/IF TYLKO w wersji stereo, więc i tak odpada.

Kolejny krok - update BIOSu, z innego źródła, niż zrobiłem to pierwotnie. Q-flash i bios F9 z tanieprocesory.pl - po ponownym uruchomieniu instalka Win10 poszła bez problemu :)

Prawdopodobnie ten modowany BIOS coś sknocił, jak barwniak wspomniał. Dziękuję za pomoc :)

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Dnia 19.08.2018 o 16:53, Kidzi1 napisał:

A propos sugestii Dijkstra - spróbowałem też Kodi, ale zdaje się nie ma już do niego wtyczki Netflixa, przynajmniej z poiomu samego programu nie znalazłem. A poza tym przy konfiguracji wyjścia dźwiękowego programu okazało się, że sterownik do karty dźwiękowej Minta obsługuje SPD/IF TYLKO w wersji stereo, więc i tak odpada.

Ona nigdy nie była oficjalna, musisz repo Kodi doinstalować. Googlaj.
Jaka dźwiękówka? Bo jeżeli zgodna z hdaudio, to musi działać, acz w trybie LPCM będzie na pewno stereo - w kodi passthrough trzeba skonfigurować i nie może być uruchomione pulse audio. Z kolei pod pod Mate, 5.1 działa przez pulse audio, ale nie mogę się do niego dobrać bezpośrednio przez ALSA, coś niepoprawnie jest wykrywane. Pod sesje kodi i mate podpiąłem różne skrypty i w zależności co uruchamiam, mam PulseAudio albo nie i jest OK. A, no właśnie - Kodi lepiej zainstalować z pakietem stand-alone, czyli może działać jako samodzielne środowisko graficzne, a nie aplikacja odpalona z Mate/Cinnamon/XFCE czy jaki tam desktop wybrałeś - tak jest prościej i mniej rzeczy się kaszani. 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Nie wiem, czy temat aktualny, ale byłem zmuszony zmigrować HTPC na nowe mobo, bo stare padło. 

Ubuntu 18.04.1 + kodi 18 (aktualnie beta) - wtyczka netflixa by asciidisco działa jak marzenie, również z dźwiękiem 5.1 (passthroug) po wywaleniu pulseaudio.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Dołącz do dyskusji

Możesz dodać zawartość już teraz a zarejestrować się później. Jeśli posiadasz już konto, zaloguj się aby dodać zawartość za jego pomocą.

Gość
Dodaj odpowiedź do tematu...

×   Wklejono zawartość z formatowaniem.   Przywróć formatowanie

  Dozwolonych jest tylko 75 emoji.

×   Odnośnik został automatycznie osadzony.   Przywróć wyświetlanie jako odnośnik

×   Przywrócono poprzednią zawartość.   Wyczyść edytor

×   Nie możesz bezpośrednio wkleić grafiki. Dodaj lub załącz grafiki z adresu URL.

Ładowanie

Aktualności

Artykuły



×
×
  • Dodaj nową pozycję...

Powiadomienie o plikach cookie

Umieściliśmy na Twoim urządzeniu pliki cookie, aby pomóc Ci usprawnić przeglądanie strony. Możesz dostosować ustawienia plików cookie, w przeciwnym wypadku zakładamy, że wyrażasz na to zgodę.