Jump to content
Nefriz

Instalacja Windows 10 na dysku M2 NVMe

Recommended Posts

Witam, niedawno złożyłem nowy komputer z dyskiem M2 NVMe i nie wiem jak poprawnie zainstalować na nim Windowsa 10. Próbowałem instalować normalnie jak na zwykłym dysku SSD, ale po instalacji system nie bootuje. W BIOSie dysk jest normalnie wykrywany przez płytę główną. Dysk to Corsair MP510 240GB, a płyta MSI MPG Z390 Gaming Pro Carbon. 

Share this post


Link to post
Share on other sites

Przygotuj obraz ISO systemu przez rufusa do instalacji w trybie UEFI.

Share this post


Link to post
Share on other sites
W dniu 29.03.2019 o 21:57, FxJ napisał:

Przygotuj obraz ISO systemu przez rufusa do instalacji w trybie UEFI.

Zrobiłem to i dzieje się to samo co przy normalnym obrazie zrobionym Microsoft Creation Tool.

 

@radiergummi Nie jestem pewny czy dobrze to robię. W opcjach Boot zmieniłem tylko Boot mode select na UEFI. Tak jak na screenie poniżej, z tym że u mnie ta opcja nie jest szara i można ją normalnie zmieniać.index.php?action=dlattach;topic=268044.0

Edited by Nefriz

Share this post


Link to post
Share on other sites

Przy uruchomieniu komputera wybieram z czego ma bootować wciskając F11 wiec to bez znaczenia chyba, zresztą to nie jest screen z mojego komputera, u siebie mam 1 UEFI Hard Disk 2 UEFI USB Key reszta disabled.

Share this post


Link to post
Share on other sites

Sterownik do NVME dodajesz do instalki?

  • Upvote 1

Share this post


Link to post
Share on other sites

Instalka Win 10 ma już stery pod NVME. 

 

Przed rozpoczęciem instalki odłącz wszystkie dyski HDD/SSD i nawet DVD jak masz. Zostaw tylko ten pod NVME.

Po zainstalowaniu Windowsa i pierwszym uruchomieniu system dopiero podłącz resztę dysków/napędów.

Share this post


Link to post
Share on other sites

Może ISO masz uszkodzone? W najnowszym Rufus 3.5 w polu wyboru obrazu masz opcje pobrania ISO. Wybierasz 10 i powinieneś pobrać plik o nazwie: Win10_1809Oct_Polish_x64.iso

Potem wybierasz schemat partycjonowania na GPT i nagrywasz pliki. Nic więcej.

rufus.jpg

Share this post


Link to post
Share on other sites

A jak masz tego pena wsadzonego to bootuje?

Share this post


Link to post
Share on other sites

Wtedy bootuje tylko z pena i chce się instalować od nowa, kiedy nacisnę F11 żeby wybrać z czego ma bootować dysku SSD nie ma na liście.

Share this post


Link to post
Share on other sites

Czy masz tak ustawione przed instalacją w Biosie:MSI_SnapShot.thumb.png.e007c415d84212fbbf3446ee1c3b947d.pngChodzi o Windows 10 WHQL support na Uefi.

A i bardzo ważna rzecz. Przed instalacją przy wyborze dysku partycji jeśli są jakieś partycje to trzeba je usunąć i NIE TWORZYĆ NOWYCH tylko kliknąć dalej. Instalator sam sobie poradzi.

Bo ja zrobiłem tak:

1.  Włączenie powyższej opcji na UEFI.

2. Odpięcie wszystkich innych urządzeń dysków ze złączy sata.

3. Odpalenie instalatora z USB.

4. Pierwsze uruchomienie. Shut down.

5. Podpięcie dysków urządzeń pod sata.

6. Odpalenie i od razu do Biosu żeby tylko z M.2 Pcie bootował

MSI_SnapShot_00.thumb.png.2e23f473db32de633c70329d57621c72.png

7. I działa u mnie bez problemu.

Share this post


Link to post
Share on other sites

Boot mode wygląda u mnie tak.K8MJ72S.png

 

Nie mam możliwości ustawienia tej pierwszej opcji na UEFI, ale próbowałem z enabled i nic to nie pomogło, jedyna różnica to to że instalator Windowsa odpalał się w dużo lepszej rozdzielczości.

TBTlKG8.png

Share this post


Link to post
Share on other sites

No to jeśli masz ustawione Windows 10 WHQL Support na enabled to teraz musisz od nowa zrobić instalację Windy.

Odpinasz dyski. Uruchamiasz kompa dalej instalatora i podczas wyboru dysku usuwasz wszystkie partycje z dysku M.2. Następnie klikasz "Dalej" bez tworzenia żadnych partycji.

 

I tak gwoli ścisłości pokaż screena z ustawieniami z Rufusa przed wykonaniem pendraka butowalnego z instalatorem.

A i uaktualnij bios płyty. Może pomoże.

U mnie poszło za pierwszym razem.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.