Jump to content
chxckmvtx

Win 10 Pro na m.2 / m.2 genie error

Recommended Posts

Witam,  nowy komputer i problemy od samego początku, spróbuję się dobrze określić, może uda się problem naprawić.

Płyta: MSI MAG Z390 Tomahawk (+ najnowszy bios)

Procek: i7 9700k

Dysk M.2: Corsair MP510 480GB

System: Windows 10 Pro.

 

Po całym dniu straconym na próbach by BIOS wykrywał dysk udało się zainstalować Windows 10 Pro, dysk był włożony w slocie 2 gdzie mam dodatkowe chłodzenie, może to był błąd.

Po konfiguracji Windowsa i po zainstalowaniu części poprawek oraz sam ręcznie poinstalowałem sterowniki od płyty głównej (w tym intel optane) system nie chciał wstać, zaraz po ekranie biosu wyskakiwał komunikat: "m2 genie error, press F1 to run setup".

Rozwiązaniem by komp wstał i odpalił Windowsa normalnie było wyciągnąć baterię na 15 minut.

Zaznaczę, że w biosie miałem wyłączone M2 OPTANE, ustawiałem AHCI a nie RAID oraz Windows 10 WHQL Support options zmienione z CSM na UEFI, oraz mam najnowszy możliwy pod pod tą płytę bios.

 

System instalując poprawki na silę też instaluje intel Optane i wydaje mi się, ze to ten program jest winowajcą. Chodzi o to, że jak znowu po restarcie miałem "m2 genie error" to w biosie wszystko dotyczące m.2 było na odwrót, zamiast AHCI był właczony RAID,  zamiast UEFI był właczony CSM, M2 optane był niby wyłaczony i na szaro, zmiana tych opcji na prawidłowe i zapisanie nic nie dała - po restarcie i wejściu w BIOS dalej był włączony RAID itd. A jedyny dysk jaki mam w PC ten m2 był w biosie niewidoczny. O co chodzi? Musiałem wyjmować znowu baterię by w ogóle komputer wstał.

Dziś, kilka dni po tym wszystkim pomimo tego, że już nic nie aktualizowałem przez Windows Update odpaliłem PC i znowu wyskoczył m2 genie error...

Chwilowo podłączyłem dysk zewnętrzny + zmieniłem slot m.2 i teraz zamiast w "chłodzonym" drugim slocie jest w pierwszym bliżej procesora. BIOS widzi dysk m2. w pierwszym slocie, ale system postawiłem na zewnętrznym dysku ssd by móc coś podziałać jednak z postawieniem systemu na m2 i zażegnaniu problemu z m2 genie error.

 

Teraz pytanie: czy jeżeli dokupię identyczny dysk m.2 oraz go zamontuję i gdy znowu postawię system na dysku m.2 to czy znowu będę miał takie atrakcje? Skoro Bios sam ręcznie zmienia na RAID?

Co wtedy poustawiać w BIOSIE by wszystko było cacy?  zamiast AHCI ustawić RAID (jeżeli bios sam tego nie zrobił), czy coś jeszcze? Zrobić jak na filmiku?

 

Czy jest sens dokupować drugi m.2?

Próbowałem na wiele sposobów ale co z tego jak w biosie nie zapisywało ustawień tylko i wyłącznie tych dotyczących m.2.

Zależy mi na tym by mieć system postawiony na dysku m.2

 

Ja już wymiękam, dlatego proszę Was o pomoc, z góry dziękuję.

ps. screen z biosu jest neta dla podglądu.

 

20190904_234742.jpg

maxresdefault.jpg

Edited by chxckmvtx

Share this post


Link to post
Share on other sites

Mogę się mylić ale Optane chyba wymaga sterowników RAID. Jak zainstalowałeś system na AHCI to brakuje sterownika i system nie wstaje. Ewentualnie sprawdź kolejność bootowania - czy pierwszy jest ten Corsair lub czy można to zmienić.

Share this post


Link to post
Share on other sites

Czyli muszę zaktualizować wszystko od intela? Bo nie zrozumiałem do końca.

(edit: 21:05 Pobrałem Intel Optane ze strony mojej płyty głównej, zainstaluje i spróbuje postawić system na m2

edit2: error "brak zgodnych dysków dla pamięci inlet Optane)

 

To może tak, sytuacja sprzed chwili, ale od początku:

- dzisiaj, 4h temu postawiłem system na zewnętrznym dysku a m.2 był włożony w slot 1 (jest goły, bez systemu), w biosie w "Windows 10 WHQL" ustawiłem tryb AHCI.  BIOS widział M.2 i rozpoznał jako MP510 czyli ok.

-postawiłem system

-aktualizuje sterowniki i aktualizacje Windows, w Zarządzaniu dyskami widać m.2, jak przypisałem mu literę to go widać w Mój Komputer.

-chwile temu musiałem znowu zrestartować PC i uwaga - dysk m.2 zniknął i z Mój Komputer i z zarządzania dyskami...

- w biosie nie widać dysku, musiałem włączyć: "SETTINGS \ Advanced \ Windows OS Configuration \ Windows 10 WHQL Support" = "UEFI", po restarcie PC dysk jest znowu widoczny w Mój Komputer i w zarządzaniu dyskami.

 

Co zrobić by już więcej nie znikał?

Jak krok po kroku wykonać instalację systemu na pojedynczym dysku m2? Na 100% jest GPT.

W głównym oknie BIOSU ma być AHCI a i ustawić: SETTINGS \ Advanced \ Windows OS Configuration \ Windows 10 WHQL Support" = "UEFI", tak?

Zapisać, odpalić pena z systemem, instalacja i tyle? Jeżeli tak to wydaje mi się, że właśnie tak zrobiłem...

Czy coś jeszcze? 

 

 

Edited by chxckmvtx

Share this post


Link to post
Share on other sites
18 godzin temu, chxckmvtx napisał:

Czyli muszę zaktualizować wszystko od intela? Bo nie zrozumiałem do końca.

Nie. Jeśli ma być aktywny Intel Optane to w biosie przed instalacją musi być włączony RAID. Co prawda można to zmienić ale wymaga to trochę zabawy - https://forum-en.msi.com/index.php?topic=307186.0

Tak naprawdę to na początek proponowałbym aktualizację biosu o ile wiesz jak to zrobić.

Czysta instalacja na pojedynczym dysku m2:
- ustawić to co napisałeś: ma być AHCI i ustawić: SETTINGS\Advanced\Windows OS Configuration\Windows 10 WHQL Support" = "UEFI"
- ustawić (o ile masz taką funkcję w biosie): SETTINGS\Advanced\Integrated Peripherals\M.2/Optane Genie" = "Disabled" - "Enabled" tylko wtedy jeśli będziesz chciał użyć Intel Optane
- zainstalować system z pena (nie wiem czy coś się zmieniło w tym zakresie ale kiedyś trzeba było jeszcze przygotować pena pod uefi: http://softonet.pl/publikacje/poradniki/Co.to.jest.UEFI.czym.sie.rozni.od.BIOSu.i.jak.zainstalowac.Windows.w.komputerze.z.UEFI-poradnik,589/2).

Share this post


Link to post
Share on other sites

Mam najnowszy bios z sierpnia, wgranie było dziecinnie proste mimo że pierwszy raz to robiłem.

Jestem teraz w pracy i ciężko mi coś więcej napisać ale w takim razie mam pytanie:

Zamówiłem wczoraj drugo dysk m2, taki sam, co muszę poustawiać w biosie by zrobić macierz/raid prawidłowo i by później cyrków znowu nie było?
dzięki

Wysłane z mojego SM-N960F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
15 minut temu, chxckmvtx napisał:

Zamówiłem wczoraj drugo dysk m2, taki sam, co muszę poustawiać w biosie by zrobić macierz/raid prawidłowo i by później cyrków znowu nie było?

Zrób to co w filmiku, który załączyłeś wcześniej.

  • Like 1

Share this post


Link to post
Share on other sites

Ustaw w biosie tak jak u mnie na screenach. Odłącz wszystkie dyski oprócz m.2 zrób instalkę i tyle. Dyski podepnij dopiero po pierwszym uruchomieniu systemu po instalacji.

MSI_SnapShot_02.jpg

MSI_SnapShot_03.jpg

Share this post


Link to post
Share on other sites

Drugi screen - zgoda. Pierwszy - nie. Bo jak tak ustawi to system zainstaluje mu się bez sterowników do RAID i po restarcie będzie miał znów problem (raczej też nie uda mu się stworzyć macierzy z dysku systemowego i drugiego dysku pod windowsem). Takie ustawienie jak na pierwszym screenie tylko dla dysku nie w macierzy. Dodatkowo dla dwóch dysków M.2 w macierzy powinien też włączyć opcję "M.2/Optane Genie".

  • Upvote 1

Share this post


Link to post
Share on other sites

Zrobiłem jak na filmiku i jak pisaliście, zrobiło macież Raid 0 z dwóch dysków m2.W głównym oknie biosu włączyłem Optane i Raid, a w opcjach "włączyłem" uefi i raid, włączyłem oba dyski. Stworzyło macież Raid 0, zainstalowalem system Win 10 Pro najnowszy i po restarcie od razu wyskoczył komunikat M2 genie error.

Bios nie widzi obu dysków m2, instalator windowsa też. Co to ma być??? Mam dosyć, dlaczego to nie działa?

1 zdjęcie to przed instalacją Windy, ja już nie mam pojęcia o co chodzi...
7fdefd881a44e681686c243732eeeb95.jpg5a30b65eadf258efd087e4271f6c788b.jpg52de495da856faca7c71064491cdc851.jpg998ab54c172bffed826c8885eb3181af.jpg

Wysłane z mojego SM-N960F przy użyciu Tapatalka

Share this post


Link to post
Share on other sites
9 godzin temu, chxckmvtx napisał:

.W głównym oknie biosu włączyłem Optane 
 

może sprawdź bez włączania tego Optane - wypadałoby poczytać co to jest 

Share this post


Link to post
Share on other sites

Przestaw SATA Port1 na DISABLED. Zgodnie z instrukcją Twojej płyty:

The SATA1/ SATA5 port will be unavailable when an M.2 SATA SSD module has been installed in the M2_1/ M2_2 slot.

(edit) Tak, wiem że masz dyski NVMe PCIe ale spróbuj. Druga opcja - walnięta płyta bo już nic innego mi nie przychodzi do głowy.

Edited by Jacekk44

Share this post


Link to post
Share on other sites

@tesel W biosie tej płyty opcja M.2/Optane Genie oznacza że dotyczy M.2 lub Optane. To taki "ułatwiacz" konfiguracji pod raid zrobiony z dwóch dysków M.2 lub pod zestaw Optane i HDD.

Z forum MSI:
Mam pytanie odnośnie biosu jakie zastosowanie mają:
1. SATA Mode (AHCI Mode - Raid/Optane)
2. M.2/ Optane Genie (dis. - enab.) - ?

Dość oczywiste.
1. Optane mode jeśli używasz dysku Optane, w przeciwnym wypadku SATA mode.
2. Normalnie wyłączone. Ale włączamy jeśli:
a. Mamy dysk Optane
b. Chcemy utworzyć RAID z dysków PCIe. Ta opcja jest jako "PCIe remapping".
 

Edited by Jacekk44

Share this post


Link to post
Share on other sites

Odpiszę po pracy Panowie, właśnie jadę.

Ale i bez włączonego Optane nie chciało wstać.

Obecnie mam rozdzielone oba dyski (bez raid), Ahci w głównym menu i W Setting/Advance mam UEFI i postawiłem system, mimo, ze już Windows Update wszystko poinstalował to po restarcie nie ma errora, ale czuję, że w każdej chwili może wrócić jak ostatnio.

A dla jasności - w kompie mam tylko włozone 2x dysk m.2 i nic więcej, dodatkowy dysk był tylko po to by móc odpalic system awaryjnie, na chwilę, obecnie jest odłączony i będzie dopóki znowu coś się nie pokićka.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

Aktualności

Artykuły



×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.