Jump to content

Dijkstra

Moderator
  • Content Count

    8456
  • Joined

  • Last visited

  • Days Won

    41

Posts posted by Dijkstra

  1. Podczas instalacji OS na nowym SSD stary HDD był obecny w laptopie? Jeśli tak, to pewnikiem instalator zgłupiał. I pewnie jak napisał przedmówca dysk SSD jest MBR, HDD jest GPT. Jeśli nic jeszcze nie robiłeś - najlepiej wyjmij HDD, ustaw GPT w biosie i zainstaluj OS jeszcze raz, najlepiej na SSD w miejscu HDD, bo bay DVD może (ale nie musi) mieć przycięty transfer SATA. Albo zabawa z bootrec, ale to zajmie więcej czasu. 

    Później włóż HDD, usuń partycję boot i windows (jeśli jest osobna).

  2. Zabootować instalator dowolnego linuxa z pendrive, na nim:

    dd if=/dev/random of=/dev/sd* ; dd if=/dev/zero of=/dev/sd*

    pierwsze dd zapisze powierzchnie dysku pod sd* losowymi danym, drugie zerami. Jeżeli nie robiłeś na laptopie nie wiadomo czego, to wystarczy dowolne z nich  - /dev/zero będzie szybsze.
    /dev/sd* to przykładowa ścieżka, może być różna. Dysk NVMe będzie zamontowany pod /dev/nvm*.
    Programy do wymazywania dysków zasadniczo nie robią wele więcej, niż to. 

  3. Bonjour, 

    Nie mogę znaleźć informacji jak działa przełązanie obsługiwanych urządzeń  dedykowanymi przyciskami [1,2,3] na myszy i klawiaturze; muszę przełączać każde urządzenie osobno, czy komunikują się ze sobą i robiąc to na myszy ALBO klawiaturze oba peryferia przełączają się pomiędzy urządzeniami 1, 2, 3 jednocześnie?
    Dodam, że nie mogę użyć funkcji flow ani dedykowanego softu Logitech'a - tylko unifying dongle + przełączanie mechaniczne. 

    Z góry dzięki. 

  4.  

    Hej,

    1. Sprawdź coś takiego:

    [dx@t420-manjaro ~]$ ls -salh /etc/resolv.conf && cat /etc/resolv.conf
    4,0K -rw-r--r-- 1 root root 92 kwi  1 12:05 /etc/resolv.conf
    # Generated by NetworkManager
    search hr
    nameserver 192.168.1.1
    nameserver fd3a:8cd2:abd8::1
    

    Tzn. czy resolv.conf istnieje, czy nie jest aby symlinkiem do czegoś i czy jest aktualizowany przez network managera. Po aktywacji połączenia "admin"  powinny być inne DNS, niż dla users. 

    2. Sprawdź, czy na pewno wygląda tak:

    cat /etc/NetworkManager/NetworkManager.conf
    [main]
    dns=default
    


    Musi być sekcja [main] dokładnie tak pisana a w niej wpis poniżej. 

    3. Co do priorytetów połączeń, faktycznie nie działa... co kolwiek tam nie ustawię - liczby dodatnie, ujemne - to admin dostaje połączenie users i trzeba przestawić ręcznie. 

  5. Faktycznie, potwierdzam problem - jest na styku kilku komponentów, które różnią się pomiędzy dystrybucjami i nigdy nie było zgody co do tego, jak powinny działać, zwłaszcza w środowisku wieloużytkownikowym. 

    1. W network managerze wyklikałem połączenia admin i others:
    - admin dostaje wszystko z dhcp i odklikuję w nim "wszyscy mogą używać tego połączenia" na karcie "ogólne"
    - others ma "wszyscy mogą używać tego połączenia" i tylko adres z DHCP - DNS ustawiam TPSA/orange.

    Efekt: faktycznie nie działa, tj używane są dns albo systemowe, albo fallbackowe systemd-resolvera. 

    2. Workaround:
    - sudo systemctl disable systemd-resolve
    - sudo nano /etc/NetworkManager/NetworkManager.conf - w sekcji [main] dodaj wpis dns=default
    - sudo rm /etc/resolv.conf
    - reboot

    3. U mnie działa, tj:
    - w /etc/resolv.conf lądują DNS z NetworkManagera
    - po ustawieniu others DNS TPSA przy próbie wejścia na dowolną stronę hazardową z listy mf.gov.pl ląduje przekierwany przez DNS na stronie MF (spodziewane). 

    Ale jeżeli użytkownik na prawach admina  zaloguje się i użyje połączenia admin, to nadpisze resolv.conf; aby ponownie działały DNS zdefianiowane w połączeniu others połączenie admin musi zostać rozłączone, a others połączone. 

    Jest możliwe, że mint instalowany na blachach nie podnosi lokalnego serwera DNS (systemd-resolve), dlatego na blachach działało. 

    Daj znać, jak poszło. 
     

    PS. systemd-resolver to nic za czym warto płakać, gdybyś się zastanawiał, pamiętaj jedynie że duże aktualizacje mogą go ponownie włączyć (zwłaszcza, jeżeli aktualizowane jest systemd)

  6. Hej,

    Z mintem rozstałem się dość dawno, w momencie gdy zrezygnowali z  wydania KDE. Network manager KDE pozwala na skonfigurowaniu na tej samej sieciówce wielu połączeń i wskazaniu którzy użytkownicy mogą korzystać z jakiego połączenia (w tym ethernet również) i podobną funkcjonalność miało jak pamiętam środowisko Mate. 

    Z jakiego środowiska korzystasz? Może się pobawię w wolnej chwili, dawno nie zaglądałem do Minta. 

  7. Bo to na 99% nie jest /dev/sda, tylko /dev/mapper/cośtam, albo /dev/<nazwa kontrolera>/cośtam - w zależności od kontrolera RAID.
    Niektóre kontrolery to pseudo raid - zwane też fake raid - linux widzi je "na wylot", t.j. widzi osobno raid, osobno dyski w nim partycypujące i Twój case tak wygląda trochę. Sprzętowe raid ostają zazwyczaj nazwę od chipsetu kontrolera, np. /dev/cciss, a faje raid /dev/mapper. Także w przypadku RAID, do instalacji GRUB nie powinieneś wybierać /dev/sda - powinno być tam jakieś urządzenie blokowe.

    Jeżeli Twój kontroler to fake raid (typowo: raid na płycie w chipsecie), to inną opcją jest zainstalowanie linuxa normalnie, a pojedynczym dysku, a później za pomocą liuxowego MD (multiply device)  zrobić z tego software raid - wydajność będzie taka sama, bo to się de facto niczym nie różni - fake raid używa CPU, bo nie ma własnego procesora.

    Kilkukrotnie instalowałem linuxa na RAID - co prawda 1, nie 0, ale jakoś specjalnie nie miałem z tym problemu... gdzieś się musiałeś zafiksować na czymś.

    Ale szczerze - mamy od prawie 20 lat XXI wiek. Jeżeli w Twojej zabawie nie chodzi o walor poznawczy, to kup sobie SSD, bo wolne działanie Twojego komputera to w jakiś 85% nie prędkość transferu, którą chcesz zwiększyć dodając RAID0, tylko długi czas dostępu, który zasadniczo - jeżeli w ogóle zmieni się przy RAID0, to tylko na minus - zaś dyski SSD prawie czasu dostępu nie mają.

    Adata SU650 jest tania i całkiem wydajna w swojej klasie; może nie jest to szczyt marzeń, ale adata przynajmniej ma serwis przyzwoity.

    Linux nie jest systemem bezużytecznym - korzystam z niego jako system podstawowy od jakiś 10 lat. Po prostu nie wszystko da się zrobić w instalatorze graficznym, ot co. Trza się trochę naumieć ;]
     

  8. To, co chcesz zrobić, estetyczniej IMO można ogarnąć dzięki serwerowi proxy. Stawiasz go gdzieś w LAN, a użytkownikowi w przeglądarce (najlepiej Firefox)* konfiguruje się adres proxy i cały ruch http idzie przez proxy. Typowy soft do tego to squid proxy. 

    * Większość przeglądarek bazuje na systemowych ustawieniach proxy. Jeżeli tam się je wprowadzi, to prawie cały windows się "kapnie" że ma neta, wówczas trzeba robić proxy z autoryzacją, żeby user mógł się uwierzytelnić a windows nie. 

  9. Jeżeli system masz obecnie na SSD, to windowsowy boot manager znajduje się wciąż na HDD (to on widnieje jako bootowalne urządzenie w EFI) i to z niego następuje bootowanie - tak bywa, gdy instaluje się windowsa na kolejnym dysku nie odłączając pierwszego. 

    Prawdopodobnie najprościej będzie wyjąć HDD, zabootować ponownie z pendrive i wybrać w instalatorze naprawę systemu. Partycja MSR jest na obu dyskach, ale prawdopodobnie tylko na HDD jest ustwiona jako active, instalator to poprawi, jak usuniesz HDD. 

    Druga opcja - pod windowsem za pomocą diskpart ustawić flagi na partycji MSR na SSD (albo gparted) - wówczas w EFI w boot options powinien się pojawić SSD jako bootowalne urządzenie.

    • Upvote 2
  10. Płytka doszła i jest całkiem fajna. Na ubuntu 18 i kodi 18 beta HEVC main10 4K działa w HW.
    z minusów:
    - do aktualizacji firmware do 1.3 potrzebowałem jednak windowsa - z winPE flasher nie ruszał, nie mógł się dogadać z mikroukładem TXE (za pewne z powodu braku sterownika)
    - instrukcja AsRocka do flasha jest... niejednoznacza. Straciłem z godzinę, zanim wykminiłem, że kompa należy uruchomić ze zwartą zworką od TXE, a nie tylko jednorazowo zewrzeć
    - nie wspiera BIOS boot, tylko EFI. Trudno, takie czasy...

    Z plusów:
    + ubuntu 18 zainstalowało się od kopa
    + po zgraniu kluczowych configów ze starego ubuntu 14, wszystko mi działa od kopa bez konfiguracji
    + ładnie wykrywa urządzenia USB - kiedy płyta jest wyłączona, nie zasila DAC'a, dysków itp - ale zasila odbiornik pilota, ergo poweron z pilota działa.
     

    Zrzut ekranu z 2018-08-31 21-08-30.png

     

    Natomiast brakujący coaxial ogarnąłem chińskim DAC  na PCM2704 za 29zł, jakich pełno na allegro (na aliexpress za < 5$, ale mi się czekać nie chciało). Analog nawet ładnie gra w słuchawkach - gorzej niż FIIO E10, ale szerszą sceną.

    image.png

    Kontroler 4x SATA PCIE x1 na Marvell 88SE9215 w drodze.  

  11. Ogólnie to:
    1. co dzieje się, jak próbujesz uruchomić apkę z dysku systemowego? Powinien wyskoczyć monit o podniesienie uprawnień w bezpiecznym pulpicie - opcja 3 od góry. Jeżeli się to nie dzieje, być może coś mocno nie tak z Twoim OS.
    2. Generalnie idea jest taka: uruchamiasz coś, co nie jest częścią standardowej instalacji windows - wyskakuje Ci okienko na przyciemnionym pulpicie z prośbą o potwierdzenie. Jeżeli chcesz to zmienić tak, aby działało jak na koncie BUILTIN/Administrator, to przede wszystkim, na Twoim screenie:
    - opcja nr. 5 - wyłączony
    - opcja nr. 3 od dołu: - podnieś bez monitu czy jakoś tak. 

     

  12. Na windows pro:

    Uruchom: secpol.msc
    Znajdź takie ustawienia i ustaw, jak poniżej - nie używam polskiego OS, więc nie wiem, jak to się nazywa po polsku:
    image.png

    Reboot

    Możesz też w msconfig zjechać z suwakiem UAC na sam dół, ale od dłuższego czasu nie jest to do końca rekomendowane. 

    PS. Twój user jest oczywiście w grupie administratorów komputera?

  13. No J4105  z J1800 nie ma zbyt wiele wspólnego...
    Z tego, co widzę, na dzień dobry trzeba paczować TXE, bo bugi jakieś są. I w dodatku spod windows... którego nie mam.

    Tak czy owak, zamówiłem, dawno nic nie dłubałem. 

  14. Bawił się ktoś płytką AsRock J4105-ITX? Zintegrowane, pasywnie chłodzone gemini lake TDP 10W.

    Mój leciwy AsRock B75 Pro3-M LGA1155 wziął i padł po latach, a z HTPC x86 nie chcę rezygnować (robi też za NAS, FTP, WWW i kilka innych rzeczy okazjonalnie). Boli mnie brak coaxiala, a pciex x1 raczej zajmę kontrolerem SATA, bo 4 porty będzie mi za mało. 

  15. Dnia 19.08.2018 o 16:53, Kidzi1 napisał:

    A propos sugestii Dijkstra - spróbowałem też Kodi, ale zdaje się nie ma już do niego wtyczki Netflixa, przynajmniej z poiomu samego programu nie znalazłem. A poza tym przy konfiguracji wyjścia dźwiękowego programu okazało się, że sterownik do karty dźwiękowej Minta obsługuje SPD/IF TYLKO w wersji stereo, więc i tak odpada.

    Ona nigdy nie była oficjalna, musisz repo Kodi doinstalować. Googlaj.
    Jaka dźwiękówka? Bo jeżeli zgodna z hdaudio, to musi działać, acz w trybie LPCM będzie na pewno stereo - w kodi passthrough trzeba skonfigurować i nie może być uruchomione pulse audio. Z kolei pod pod Mate, 5.1 działa przez pulse audio, ale nie mogę się do niego dobrać bezpośrednio przez ALSA, coś niepoprawnie jest wykrywane. Pod sesje kodi i mate podpiąłem różne skrypty i w zależności co uruchamiam, mam PulseAudio albo nie i jest OK. A, no właśnie - Kodi lepiej zainstalować z pakietem stand-alone, czyli może działać jako samodzielne środowisko graficzne, a nie aplikacja odpalona z Mate/Cinnamon/XFCE czy jaki tam desktop wybrałeś - tak jest prościej i mniej rzeczy się kaszani. 

  16. Kodi obsługiwał nieoficjalną wtyczkę do netflix'a od wersji 18, ale nigdy nie testowałem - siedzę cały czas na 17, bo mam stare ubuntu i nie chce mi się aktualizować. Windows jako OS pod MediaCenter/HTPC odpuściłem już dawno temu (w zasadzie, to ogólnie odpuściłem), bo zawsze znajdował sposób, żeby wywalić jakiegoś popupa na interface Kodi, przerwać odtwarzanie albo się wywalić. 

    Spróbuj pobawić się Androidem i/lub AndroidTV x86 + apką netflix'a, prawdopodobnie najmniej nerwów stracisz... ogólnie z androidem x86 nigdy nie miałem większych problemów, a używałem go dość długo na notebooku (jeden z moich pracodawców miał VPN, który działa tylko na Windows, IOS lub Android, a ja zasadniczo od dawna raczej linuxowy jestem). Instaluje się dość łatwo, więc po prostu zainstaluj, sprawdź, czy łyknie Twoją kartę dźwiękową/passthrouch/DAC, wrzuć apkę Netflix i sprawdź, czy działa. Będziesz musiał poczytać, jak zainstalować Gapps, a przynajmniej GoogleStore, bo w czystym x86 ich raczej na pewno nie będzie (licencja Androida). Albo samo APK z neta, ale trzeba byłoby zaufane źródło znaleźć.

    Natomiast... odpowiedz sobie, czy warto.  Chromecasta lub jakegoś STB z Androidem kupisz <200zł, a setup z Xeonem będzie żarł prąd jak wściekły i pewnie ani piękny, ani cichy, ani wygodny nie będzie. 
    https://www.komputronik.pl/product/501134/savio-smart-tv-box-basic-one.html

    • Like 1
    • Upvote 1
    • Downvote 1
  17. Cytat
    7 godzin temu, radiergummi napisał:

    Wyjmij HDD i zainstaluj system jeszcze raz w trybie UEFI usuwając wszystkie istniejące partycje na SSD podczas instalacji.

    A przynajmniej najpierw pokaż sceena z przystawki do zarządzania dyskami tak, aby wszystkie partycje było widać;  nie wiem, jak przy EFI, ale przy BIOS Windows ma swoje teorie co do tego, który dysk jest główny i może być tak, iż boot loader windowsa znajduje się na HDD, a sam windows jest na SSD i oba dyski są niezbędne do uruchomienia komputera. U mnie przynajmniej zawsze się tak kończyło, gdy zapomniałem odpiąć HDD na czas instalacji.

     

  18. No wklejałem Ci tego linka...  masz tam podane ustawienia gpedit/regkey, które pozwalają na obejście tego. 

    Mam to samo w robocie,  bo poprawki na serwery idą u nas innymi torami, niż na desktopy - ale problem na razie zgłosiła jedna osoba, z jednego kompa do jednego serwera i nie mam jak zweryfikować, jak najszybciej to obejść.

    Po weekendzie pewnie się tickety posypią... 

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.